Resolvendo problema do GLPI – HTTP ERROR 500

Vos trago, como resolver o “HTTP ERROR 500” que pode ocorrer após fazer alguma alteração nos arquivos do GLPI, ou instalar algum plugin.

Primeiro gostaria de informar de quem indicou essa solução foi o Stevenes Donatonessa postagem.

Segundo o mesmo o problema ocorre por alguma variante incompatível com a versão do seu GLPI, seja por modificação manual de um dos arquivos ou instalação de um plugin.

Arquivos:

  • commonglpi.class.php
  • html.class.php
  • search.class.php
  • index.php

Para resolver esse problema, o mais sugestivo, é substituir os arquivos acima, para os da versão original do GLPI, na pasta /inc e a index.php na pasta principal.

Vale ressaltar que deve-se sempre copiar da mesma versão que você possui, nem sempre é da versão mais atualizada, isso pode causar ainda mais problemas.

Exemplo, seu GLPI é versão 0.85, você precisa baixar a versão 0.85 original, e copiar os arquivos da versão original para a sua pasta atual do GLPI, substituindo os mesmos.

Link oficial das versões antigas do GLPI: Clique aqui e aqui

Recomendamos sempre o uso das versões especificas de plugins e modificações para a sua versão do GLPI, mantenha sempre na versão mais atualizada e instável.

Versão com os principais plugins atualizados, instável, e que utilizamos: 9.1.1

Deixe uma resposta