Resolvendo erro do glpi “Seu interpretador PHP foi compilado sem suporte a funções IMAP”

Esse erro foi reportado no meu antigo fórum por um usuário chamado Bebeto Francisco, o mesmo postou o problema e encontrou a solução, para deixar aqui registrado o que o mesmo usou para corrigir segue:

Mensagem do erro:

Seu interpretador PHP foi compilado sem suporte a funções IMAP
Impossível usar o servidor de e-mail como fonte externa de conexão

Os dados que ele forneceu que estava usando eram:

  • Ubuntu Server 16.04 com PHP 7

O que ele tentou fazer primeiro foi obviamente instalar o imap via prompt de comando do ubuntu, com o comando

# apt-get update
# apt-get install php-imap
# service apache2 restart

Para ele não resolveu de imediato, mas caso persista, o que resolveu foi atualizar o PHP da versão 7 para a 7.1, dito isso recomendo o seguinte comando

# apt-get update
# apt-get upgrade

Caso alguém mais tenha esse problema, não exite em deixar um comentário se funcionou ou não, adios

Deixe uma resposta