Como instalar plugins em versões mais recentes DO GLPI

Novas versões sempre são um problema na questão de plugins antigos, porque se acabou de sair uma nova versão do GLPI como exemplo, provavelmente demore alguns dias ou semanas para os plugins ser atualizado.

Para contornar isso podemos fazer uma “manha” no GLPI, o forçando a deixar instalar aquele plugin que não tem uma versão adequada para sua versão.

Lembrando que o método abaixo pode não funcionar em todos os plugins.

Vale ressaltar que é bom sempre fazer um backup do banco de dados por garantia.

Basta editar o arquivo setup.php, que se encontra na pasta do plugin antes da instalação, e editar a seguinte linha para uma versão entre a sua é uma, mesmo que ela nem exista.

if (version_compare(GLPI_VERSION, '9.2', 'lt') || version_compare(GLPI_VERSION, '9.3', 'ge')) {

Essa dica foi postada nesse link.

Esse post é meio que um complemento dessa outra postagem abaixo, caso o de cima não tiver dado certo, é quiser testar

1 Comment

Deixe uma resposta