A extensão ldap, imap,APCu, xmlpc,mysqli,curl,gd não está presente/faltando do GLPI

Na hora da instalação do GLPI ele faz algumas checagens e um dos problemas que pode aparecer é alguma extensão do php estar faltando, hoje vou ensinar como habilitar e resolver esse problema para prosseguir com a instalação.

Instalando o GLPI em um novo servidor, e sempre algo a ficar atento, porque tem algumas mudanças a se fazer antes de conseguir realizar a instalação.

Hoje, vamos deixar essa telinha aqui, toda verdinha.

Extensões do GLPI ativadas e prontas para prosseguir com a instalação

Se o processo for no windows, basta editar o arquivo php.ini e habilitar as linhas correspondentes aos pontos que está apresentando erro.

Para habilitar, basta descomentar a linha da devida extensão tirando o “;” do inicio da linha, depois salve o arquivo e reinicie o apache2 para aplicar as alterações, e teste.

No linux, e um pouco mais fácil eu diria, se o S.O. do servidor do debian ou algum derivante dele, basta executar o comando abaixo já logado como root, se não basta adicionar sudo antes do comando para pedir credenciais de acesso.

apt-get install ca-certificates apache2 libapache2-mod-php5 php5-cli php5 php5-gd php5-imap php5-ldap php5-mysql php-soap php5-xmlrpc zip unzip bzip2 unrar-free php5-snmp php5-curl -y

Deixar ele instalar os pacotes.

Obs: Um apt-get update antes sempre ajuda ok?

Obs²: Se for outro S.O Linux o comando de instalar geralmente é parecido como yum install

Após a instalação dos pacotes na sua distribuição linux, reinicie o apache2 com o comando abaixo.

/etc/init.d/apache2 restart

Agora basta prosseguir com a instalação do GLPI normalmente

1 Comment

Deixe uma resposta