Pré requisitos para instalação do GLPI

Requisitos Minimos para instalação do GLPI

Um ponto interessante sobre a instalação do GLPI e seus requisitos mínimos para instalação em qualquer ambiente, desde que atenda esses requisitos vai conseguir ter um ambiente do GLPI rodando sem problemas.


Servidor WEB

O servidor web que o GLPI necessita para rodar necessita oferecer suporte a PHP, tais como:

  • Apache2
  • Nginx
  • Microsoft IIS

Demais serviços web não foram testados e podem não funcionar como esperado.


Extensões do PHP

Recomenda-se utilizar a versão mais atualizada do php de acordo com a versão do seu GLPI para melhor desempenho

Extensões Obrigatórias:

Extensões Opcionais:

Mesmo que as extensões abaixo não sejam obrigatórias, é de recomendação que as instale para melhor utilização das funções do GLPI.

Temos um artigo mais especifico sobre extensões caso queira saber mais:


Versão do PHP

VERSÃO DO GLPIVersão minima PHPversão maxima PHP
9.4.X5.67.4
9.5.X7.28.0
10.0.X7.48.1
Versão do PHP recomendada por versão

Temos um artigo e como encontrar a versão do php do seu servidor atualmente.


Banco de Dados

Para que o GLPI funcione corretamente é necessário utilizar um dos serviços abaixo, demais serviços de gerenciar banco de dados o GLPI oficialmente não tem suporte.

  • MySQL – Versão 5.7 ou posterior
  • MariaDB – Versão 10.2 ou posterior

Configurações do php.ini

memory_limit = 64M        // max memory limit
file_uploads = on
max_execution_time = 600  // não obrigatório, mas recomendado
session.auto_start = off
session.use_trans_sid = 0 // não obrigatório, mas recomendado

Configurações Recomendas – Relatos TI

Essas são configurações não oficiais, e que recomendo para o bom funcionamento do GLPI.

memory_limit = 512M
max_file_uploads = 99
post_max_size = 128M
upload_max_filesize = 128M  

Como não há uma recomendação de uso de memória, sistema operacional ou outras especificações de forma oficial, segue o que recomendo de uso mínimo em servidor ou serviço de hospedagem online mínimos para comportar o GLPI sem problemas.

O uso de um servidor exclusivo linux não é obrigatório, mas é exatamente recomendado pois é muito melhor de gerenciar e personalizar caso necessite de algo, caso não for necessitar de muitas personalizações ou quer testar o GLPI utilize algum serviço de hospedagem web mesmo.


Informações atualizadas em 12/03/2022

  • Sempre vou manter atualizado essa postagem para fins de consultas
  • Informações retiradas do site oficial do GLPI
Software Livre Relatos TI
Software Livre Relatos TI

Comenta aí