Instalando qualquer plugin em versões incompatíveis no GLPI

No GLPI, os plugins para serem instalados existem limitações de versões que são totalmente compatíveis e que os desenvolvedores testaram, está tudo bonitinho e certo, porém muitas vezes vemos aquele plugin incrível que você usava em uma versão anterior ou até mesmo na lista de plugins oficiais, e a versão do seu GLPI e antiga ou muito nova, enfim fora do que é indicado para aquele plugin.

Muitos acabam desistindo do plugin por essa limitação, por isso resolvi informar como “deixar” o plugin ser instalado em sua versão, mas vale lembrar que o plugin foi feito para aquela versão especifica por algum motivo, seja por compatibilidade, recursos que não existe em certas versões, então

CUIDADO COM ESSE PROCESSO

Todo plugin tem o arquivo setup.php dentro das sua pasta raiz, procure por essas linhas ou similares, e comente com um /* no inicio do código é */ no final do código, e salve o arquivo.

function plugin_officeonline_check_prerequisites() {
   global $DB, $LANG;

    // Strict version check (could be less strict, or could allow various version)
   if (version_compare(GLPI_VERSION, '9.3', 'lt') || version_compare(GLPI_VERSION, '9.4', 'ge')) {
      echo "This plugin requires GLPI >= 9.3 and < 9.4";
      return false;
   }

   return true;
}

Tente instalar o plugin recarregando a página, e provavelmente não vai aparecer o botão habilitar, como no exemplo abaixo, use o botão de atalho quando instala para conseguir habilitar

Adendo: Caso estiver aparecendo alguma mensagem de incompatibilidade, pode procurar a versão minima e máxima no campo:

'requirements'   => ['glpi' => ['min' => '9.3',
                                'max' => '9.5?]]];

E edite e salve a versão máxima desejada, deve resolver o seu problema 

2 Comments

Deixe uma resposta